BGP Internal Route Redistribution to other IGPs

The figure shown below depicts the topology setup used for this configuration.

Figure 1. BGP Configuration and Testing Topology for BGP Internal route redistribution


Use the following commands to configure BGP routing.

  1. To enable BGP in Router R1:

    Execute the following commands:

    • Enter the Global Configuration Mode.
    iS5comm# configure terminal
    • Enter the Autonomous System (AS) number in R1.
    iS5comm(config)# as-num 100
    • Configure the router-id in R1.
    iS5comm(config)# router-id 12.0.0.1
    • Enable BGP in R1.
    iS5comm(config)# router bgp 100
    • Configure R2 (with as-num 200) as external peer in R1.
    iS5comm(config-router)# neighbor 12.0.0.2 remote-as 100

  2. To enable BGP in Router R2:

    Execute the following commands:

    • Enter the Global Configuration Mode.
    iS5comm# configure terminal
    • Enter the Autonomous System (AS) number in R2.
    iS5comm(config)# as-num 100
    • Configure the router-id in R2.
    iS5comm(config)# router-id 12.0.0.2
    • Enable BGP in R2.
    iS5comm(config)# router bgp 100
    • Configure R1 (with as-num 100) as internal peer in R2.
    iS5comm(config-router)# neighbor 12.0.0.1 remote-as 100

  3. Verify that the BGP session between the internal peers R1 and R2 is established, using the following show commands in R1 and R2.

    Type the following:

    • R1: View the BGP summary information.
    iS5comm# show ip bgp summary
    BGP router identifier is 12.0.0.1, local AS number 100
    BGP table version is 0
    Neighbor Version AS MsgRcvdMsgSent Up/DownState/PfxRcd
     -------------------------------- ----------------
    12.0.0.2  4     200  2      2        00:00:00:23 Established

    iS5comm# show ip bgp neighbor
    BGP neighbor is 12.0.0.2, remote AS 100, internal link
    BGP version 4, remote router ID 12.0.0.2
    BGP state = Established, up for 3 minutes 11 seconds
    Configured BGP Maximum Prefix Limit 100
    Configured Connect Retry Count 5
    Current Connect Retry Count 0
    Peer Status : NOT DAMPED
    Rcvd update before 0 secs, hold time is 120, keepalive interval is 30 secs
    Neighbors Capability:
    Route-Refresh: Advertised and received
    Address family IPv4 Unicast: Advertised and received
    Received 8 messages, 0 Updates
    Sent 8 messages, 0 Updates
    Route refresh: Received 0, sent 0.
    Minimum time between advertisement runs is 30 seconds
    Connections established 1 time(s)
    Local host: 12.0.0.1, Local port: 179
    Foreign host: 12.0.0.2, Foreign port: 49152
    Last Error: Code 0, SubCode 0.

    • R2: View the BGP summary information.
    iS5comm# show ip bgp summary
    BGP router identifier is 12.0.0.2, local AS number 200
    BGP table version is 0
    Neighbor Version AS MsgRcvdMsgSent Up/DownState/PfxRcd
     -------------------------------- ----------------
    12.0.0.1  4     100  2      2        00:00:00:6 Established

    iS5comm# show ip bgp neighbor
    BGP neighbor is 12.0.0.1, remote AS 100, internal link
    BGP version 4, remote router ID 12.0.0.1
    BGP state = Established, up for 3 minutes 55 seconds
    Configured BGP Maximum Prefix Limit 100
    Configured Connect Retry Count 5
    Current Connect Retry Count 0
    Peer Status : NOT DAMPED
    Rcvd update before 0 secs, hold time is 120, keepalive interval is 30 secs
    Neighbors Capability:
    Route-Refresh: Advertised and received
    Address family IPv4 Unicast: Advertised and received
    Received 9 messages, 0 Updates
    Sent 9 messages, 0 Updates
    Route refresh: Received 0, sent 0.
    Minimum time between advertisement runs is 30 seconds
    Connections established 1 time(s)
    Local host: 12.0.0.2, Local port: 49152
    Foreign host: 12.0.0.1, Foreign port: 179
    Last Error: Code 0, SubCode 0.

    • Add static route in R2:
    iS5comm# configure terminal
    iS5comm(config)# ip route 91.0.0.0 255.0.0.0 90.0.0.3
    iS5comm(config)# exit
    iS5comm# show ip route
    C 12.0.0.0/8 is directly connected, vlan1
    C 90.0.0.0/8 is directly connected, vlan2
    S 91.0.0.0/8 [-1] via 90.0.0.3

    • In R2, redistribute the static route into BGP:
    iS5comm# configure terminal 
    iS5comm(config)# router bgp 100
    iS5comm(config-router)# redistribute static
    iS5comm(config-router)# end

    • Verify the BGP route in R2
    iS5comm# show ip bgp rib
    BGP table version is 1,local router ID is 12.0.0.1
    Status codes: d damped* valid, > best, i - internal
    Origin codes: i - IGP, e - EGP, ? - incomplete
    Network Next Hop Metric LocPrf Path
    ------- ---- --- ------------ ----
    *>i   91.0.0.0/8 12.0.0.1 100   ?

    • iS5comm# show ip route
    C 12.0.0.0/8 is directly connected, vlan1B 91.0.0.0/8 [-1] via 12.0.0.1

  4. Execute the following commands to configure RIP routing:

    Execute the following commands:

    To enable RIP in Router R1, perform the following.

    • Enter the Global Configuration Mode.
    iS5comm# configure terminal
    • Enable RIP globally in R1.
    iS5comm(config)# router rip
    • Enable RIP over the interface vlan 2 (IP address 20.0.0.1).
    iS5comm(config-router)# neighbor 12.0.0.2 remote-as 100

    To enable RIP in Router R3, perform the following:

    • Enter the Global Configuration Mode.
    iS5comm# configure terminal
    • Enable RIP globally in R3.
    iS5comm(config)# router rip
    • Enable RIP over the interface vlan 2 (IP address 20.0.0.3).
    iS5comm(config-router)# network 20.0.0.3
  5. Verify the ip route in R3.

    Execute the following commands:

    iS5comm# show ip route
    Codes: C - connected, S - static, R - rip, B - bgp, O - ospf
    Vrf Name:          default
    ---------
    C 12.0.0.0/8  is directly connected, vlan1
    C 20.0.0.0/8  is directly connected, vlan2

  6. Configure to redistribute internal BGP routes to other IGP protocols such as RIP in R1.

    Execute the following commands:

    iS5comm# configure terminal
    iS5comm(config)# router bgp 100
    iS5comm(config-router)# bgp redistribute-internal
    iS5comm(config-router)# end

    • In R1, redistribute the static route into BGP:
    iS5comm# configure terminal 
    iS5comm(config)# router bgp 100
    iS5comm(config-router)# redistribute bgp
    iS5comm(config-router)# end

  7. Verify the ip route in R3.

    Execute the following commands:

    iS5comm# show ip route
    Codes: C - connected, S - static, R - rip, B - bgp, O - ospf
    Vrf Name:          default
    ---------
    C 12.0.0.0/8  is directly connected, vlan1
    C 20.0.0.0/8  is directly connected, vlan2
    R 91.0.0.0/8  [4] via 20.0.0.1