VRRP version 3 extends capability to IPv6 in addition to IPv4 and supports interoperability in multi-vendor environments. RFC 5798 defines VRRP version 3.
The Virtual Router Redundancy Protocol (VRRP) for IPv6 provides a much faster switchover to an alternate default router than can be obtained using standard neighbor discovery (ND) procedures. Using VRRP, a Backup router can take over for a failed default router in around three seconds (using VRRP default parameters). This is done without any interaction with the hosts and a minimum amount of VRRP traffic.
Version 3 supports:
When this configuration is enabled, packets addressed to a virtual router that does not own the responding IPvX (i.e. either IPv4 or IPv6) addresses. For setup of VRRP v 3, refer to Figure VRRP - Topology 3 as shown below.
The following scenarios are covered in this chapter of the document.
The following initial configurations need to be performed on routers DUT, R2, R3 and R4.
On DUT (Device under Test):To configure VLAN 10 and VLAN 20 and assign the member ports and IP address, execute the following commands in Switch1.
Type the following:
iS5comm# configure terminal
iS5comm(config)#no spanning-tree
iS5comm(config)#set gvrp disable
iS5comm(config)# set gmrp disable
iS5comm(config)# shutdown garp
iS5comm(config)# interface gigabitethernet 0/2
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface gigabitethernet 0/3
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface gigabitethernet 0/4
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface gigabitethernet 0/5
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# vlan 10
iS5comm(config-if)# ports gigabitethernet 0/2
iS5comm(config-if)# exit
iS5comm(config)# vlan 20
iS5comm(config-if)# ports gigabitethernet 0/3
iS5comm(config-if)# exit
iS5comm(config)# vlan 60
iS5comm(config-if)# ports gigabitethernet 0/4
iS5comm(config-if)# exit
iS5comm(config)# vlan 70
iS5comm(config-if)# ports gigabitethernet 0/6
iS5comm(config-if)# exit
iS5comm(config)# vlan 10
iS5comm(config-if)# interface gigabitethernet 0/2
iS5comm(config-if)# switchport pvid 10
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# vlan 20
iS5comm(config-if)# interface gigabitethernet 0/3
iS5comm(config-if)# switchport pvid 20
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# vlan 60
iS5comm(config-if)# interface gigabitethernet 0/4
iS5comm(config-if)# switchport pvid 10
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# vlan 70
iS5comm(config-if)# interface gigabitethernet 0/5
iS5comm(config-if)# switchport pvid 70
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface vlan 10
iS5comm(config-if)# ip address 20.0.0.1 255.255.255.0
iS5comm(config-if)# ip address 20.0.1.1 255.255.255.0 secondary
iS5comm(config-if)# ip address 20.0.2.1 255.255.255.0 secondary
iS5comm(config-if)# ip address 20.0.3.1 255.255.255.0 secondary
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface vlan 20
iS5comm(config-if)# ip address 25.0.0.1 255.255.255.0
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface vlan 60
iS5comm(config-if)# ip address 60.0.0.1 255.255.255.0
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface vlan 70
iS5comm(config-if)# ip address 70.0.0.1 255.255.255.0
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# show vlan port config
Vlan Port configuration table
-------------------------------
Port Gi0/1
Bridge Port Type : Customer Bridge Port
Port Vlan ID : 1
Port Acceptable Frame Type : Admit All
Port Mac Learning Status : Enabled
Port Ingress Filtering : Enabled
Port Mode : Hybrid
Port Gvrp Status : Disabled
Port Gmrp Status : Disabled
------------------------------------------------------
Port Gi0/2
Bridge Port Type : Customer Bridge Port
Port Vlan ID : 10
Port Acceptable Frame Type : Admit All
Port Mac Learning Status : Enabled
Port Ingress Filtering : Enabled
Port Mode : Hybrid
Port Gvrp Status : Disabled
Port Gmrp Status : Disabled
------------------------------------------------------
Port Gi0/3
Bridge Port Type : Customer Bridge Port
Port Vlan ID : 20
Port Acceptable Frame Type : Admit All
Port Mac Learning Status : Enabled
Port Ingress Filtering : Enabled
Port Mode : Hybrid
Port Gvrp Status : Disabled
Port Gmrp Status : Disabled
------------------------------------------------------
Port Gi0/4
Bridge Port Type : Customer Bridge Port
Port Vlan ID : 60
Port Acceptable Frame Type : Admit All
Port Mac Learning Status : Enabled
Port Ingress Filtering : Enabled
Port Mode : Hybrid
Port Gvrp Status : Disabled
Port Gmrp Status : Disabled
------------------------------------------------------
Port Gi0/5
Bridge Port Type : Customer Bridge Port
Port Vlan ID : 70
Port Acceptable Frame Type : Admit All
Port Mac Learning Status : Enabled
Port Ingress Filtering : Enabled
Port Mode : Hybrid
Port Gvrp Status : Disabled
Port Gmrp Status : Disabled
------------------------------------------------------
Type the following:
iS5comm# configure terminal
iS5comm(config)#no spanning-tree
iS5comm(config)#set gvrp disable
iS5comm(config)# set gmrp disable
iS5comm(config)# shutdown garp
iS5comm(config)# interface gigabitethernet 0/2
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface gigabitethernet 0/3
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# vlan 10
iS5comm(config-if)# ports gigabitethernet 0/2
iS5comm(config-if)# exit
iS5comm(config)# vlan 30
iS5comm(config-if)# ports gigabitethernet 0/3
iS5comm(config-if)# exit
iS5comm(config)# vlan 10
iS5comm(config-if)# interface gigabitethernet 0/2
iS5comm(config-if)# switchport pvid 10
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# vlan 30
iS5comm(config-if)# interface gigabitethernet 0/3
iS5comm(config-if)# switchport pvid 30
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface vlan 10
iS5comm(config-if)# ip address 20.0.0.2 255.255.255.0
iS5comm(config-if)# ip address 20.0.1.2 255.255.255.0 secondary
iS5comm(config-if)# ip address 20.0.2.2 255.255.255.0 secondary
iS5comm(config-if)# ip address 20.0.3.2 255.255.255.0 secondary
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface vlan 30
iS5comm(config-if)# ip address 35.0.0.2 255.255.255.0
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
Type the following:
iS5comm# configure terminal
iS5comm(config)#no spanning-tree
iS5comm(config)#set gvrp disable
iS5comm(config)# set gmrp disable
iS5comm(config)# shutdown garp
iS5comm(config)# interface gigabitethernet 0/2
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface gigabitethernet 0/3
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# vlan 10
iS5comm(config-if)# ports gigabitethernet 0/2
iS5comm(config-if)# exit
iS5comm(config)# vlan 500
iS5comm(config-if)# ports gigabitethernet 0/3
iS5comm(config-if)# exit
iS5comm(config)# vlan 10
iS5comm(config-if)# interface gigabitethernet 0/2
iS5comm(config-if)# switchport pvid 10
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# vlan 50
iS5comm(config-if)# interface gigabitethernet 0/3
iS5comm(config-if)# switchport pvid 50
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface vlan 10
iS5comm(config-if)# ip address 20.0.0.3 255.255.255.0
iS5comm(config-if)# ip address 20.0.1.3 255.255.255.0 secondary
iS5comm(config-if)# ip address 20.0.2.3 255.255.255.0 secondary
iS5comm(config-if)# ip address 20.0.3.3 255.255.255.0 secondary
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface vlan 50
iS5comm(config-if)# ip address 50.0.0.2 255.255.255.0
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
Type the following:
iS5comm# configure terminal
GVRP, GMRP,
and GARP if they are running
on the switchiS5comm(config)#no spanning-tree
iS5comm(config)#set gvrp disable
iS5comm(config)# set gmrp disable
iS5comm(config)# shutdown garp
iS5comm(config)# interface gigabitethernet 0/2
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface gigabitethernet 0/3
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface gigabitethernet 0/4
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface gigabitethernet 0/5
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface gigabitethernet 0/6
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface gigabitethernet 0/7
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# vlan 40
iS5comm(config-if)# ports gigabitethernet 0/2
iS5comm(config-if)# exit
iS5comm(config)# vlan 20
iS5comm(config-if)# ports gigabitethernet 0/3
iS5comm(config-if)# exit
iS5comm(config)# vlan 30
iS5comm(config-if)# ports gigabitethernet 0/4
iS5comm(config-if)# exit
iS5comm(config)# vlan 30
iS5comm(config-if)# ports gigabitethernet 0/4
iS5comm(config-if)# exit
iS5comm(config)# vlan 60
iS5comm(config-if)# ports gigabitethernet 0/6
iS5comm(config-if)# exit
iS5comm(config)# vlan 70
iS5comm(config-if)# ports gigabitethernet 0/6
iS5comm(config-if)# exit
iS5comm(config)# vlan 40
iS5comm(config-if)# interface gigabitethernet 0/2
iS5comm(config-if)# switchport pvid 40
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# vlan 20
iS5comm(config-if)# interface gigabitethernet 0/3
iS5comm(config-if)# switchport pvid 20
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# vlan 30
iS5comm(config-if)# interface gigabitethernet 0/4
iS5comm(config-if)# switchport pvid 30
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# vlan 50
iS5comm(config-if)# interface gigabitethernet 0/5
iS5comm(config-if)# switchport pvid 50
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# vlan 60
iS5comm(config-if)# interface gigabitethernet 0/6
iS5comm(config-if)# switchport pvid 60
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# vlan 70
iS5comm(config-if)# interface gigabitethernet 0/7
iS5comm(config-if)# switchport pvid 70
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface vlan 20
iS5comm(config-if)# ip address 25.0.0.4 255.255.255.0
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface vlan 30
iS5comm(config-if)# ip address 35.0.0.4 255.255.255.0
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface vlan 40
iS5comm(config-if)# ip address 40.0.0.4 255.255.255.0
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface vlan 50
iS5comm(config-if)# ip address 50.0.0.4 255.255.255.0
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface vlan 60
iS5comm(config-if)# ip address 60.0.0.4 255.255.255.0
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# interface vlan 70
iS5comm(config-if)# ip address 70.0.0.4 255.255.255.0
iS5comm(config-if)# no shutdown
iS5comm(config-if)# exit
iS5comm(config)# show vlan port config
Vlan Port configuration table
-------------------------------
Port Gi0/1
Bridge Port Type : Customer Bridge Port
Port Vlan ID : 1
Port Acceptable Frame Type : Admit All
Port Mac Learning Status : Enabled
Port Ingress Filtering : Enabled
Port Mode : Hybrid
Port Gvrp Status : Disabled
Port Gmrp Status : Disabled
------------------------------------------------------
Port Gi0/2
Bridge Port Type : Customer Bridge Port
Port Vlan ID : 10
Port Acceptable Frame Type : Admit All
Port Mac Learning Status : Enabled
Port Ingress Filtering : Enabled
Port Mode : Hybrid
Port Gvrp Status : Disabled
Port Gmrp Status : Disabled
------------------------------------------------------
Port Gi0/3
Bridge Port Type : Customer Bridge Port
Port Vlan ID : 20
Port Acceptable Frame Type : Admit All
Port Mac Learning Status : Enabled
Port Ingress Filtering : Enabled
Port Mode : Hybrid
Port Gvrp Status : Disabled
Port Gmrp Status : Disabled
------------------------------------------------------
Port Gi0/4
Bridge Port Type : Customer Bridge Port
Port Vlan ID : 60
Port Acceptable Frame Type : Admit All
Port Mac Learning Status : Enabled
Port Ingress Filtering : Enabled
Port Mode : Hybrid
Port Gvrp Status : Disabled
Port Gmrp Status : Disabled
------------------------------------------------------
Port Gi0/5
Bridge Port Type : Customer Bridge Port
Port Vlan ID : 70
Port Acceptable Frame Type : Admit All
Port Mac Learning Status : Enabled
Port Ingress Filtering : Enabled
Port Mode : Hybrid
Port Gvrp Status : Disabled
Port Gmrp Status : Disabled
------------------------------------------------------
On DUT:
iS5comm# configure terminal
iS5comm(config)# ip route 40.0.0.0 255.0.0.0 25.0.0.4
Type the following:
On R2:iS5comm# configure terminal
iS5comm(config)# ip route 40.0.0.0 255.0.0.0 35.0.0.4
Type the following:
On R3:iS5comm# configure terminal
iS5comm(config)# ip route 40.0.0.0 255.0.0.0 50.0.0.4
Type the following:
On R4:iS5comm# configure terminal
iS5comm(config)# ip route 20.0.0.0 255.255.255.0 25.0.0.1
iS5comm(config)# ip route 20.0.0.0 255.255.255.0 35.0.0.2
iS5comm(config)# ip route 20.0.0.0 255.255.255.0 50.0.0.3
iS5comm( config)# end
C:\Users>route ADD 0.0.0.0 MASK 0.0.0.0 20.0.0.2
where: destination^ ^mask ^gateway
C:\Users>route ADD 0.0.0.0 MASK 0.0.0.0 20.0.0.2
where: destination^ ^mask ^gateway
C:\Users>route ADD 0.0.0.0 MASK 0.0.0.0 40.0.0.4
where: destination^ ^mask ^gateway