Configuring OSPF Area Parameters

Area parameters can be configured only after enabling the OSPF process. They are configured in the Router Configuration Mode.

Configuring Stub Area

A stub area is an area in which advertisements of external routes are not allowed, which thus reduces the size of the database even more. Instead, a default summary route (0.0.0.0) is inserted into the stub area in order to reach these external routes. If you have no external routes in your network, then you have no need to define stub areas.

Execute the following commands to configure an area as a stub area.

Type the following:

  • Enter the Global Configuration Mode in ISS1.
iS5comm# configure terminal
  • Enable OSPF globally in the switch ISS1.
iS5comm(config)# router ospf
  • Configure the OSPF router-id.
iS5comm(config-router)# router-id 10.10.2.1
  • Configure the OSPF interface.
iS5comm(config-router)# network 10.4.0.1 area 0.0.0.0
iS5comm(config-router)# network 10.10.2.1 area 0.0.0.6
  • Configure the area 0.0.0.6 as a stub area.
iS5comm(config-router)# area 0.0.0.6 stub
Note:

Execute the following command to reconfigure the area 0.0.0.6 as a normal area.

iS5comm(config-router)# no area 0.0.0.6 stub
Note:

For Sample Configuration for Stub area, ASBR and route redistribution, refer to Figure - Topology for Configuration of Stub area, ASBR and route redistribution.

  • Exit from the Interface Configuration mode.
iS5comm(config-if)# end

Configuring ASBR Router

Routers that act as gateways (redistribution) between OSPF and other routing protocols (IGRP, EIGRP, RIP, BGP, Static) or other instances of the OSPF routing process are called autonomous system boundary router (ASBR).

Execute the following commands to configure a router as an ASBR router.

Type the following:

  • Enter the Global Configuration Mode in ISS1.
iS5comm# configure terminal
  • Enable OSPF globally in the switch ISS1.
iS5comm(config)# router ospf
  • Configure the OSPF router-id.
iS5comm(config-router)# router-id 10.10.2.1
  • Configure the ASBR router.
iS5comm(config-router)# asbr router
Note:

Disable the ASBR router by executing the following command

iS5comm(config-router)# no asbr router
Note:

For Sample Configuration for Stub area, ASBR and route redistribution, refer to Figure - Topology for Configuration of Stub area, ASBR and route redistribution.

  • Exit from the Interface Configuration mode.
iS5comm(config-if)# end

Configuring Redistribution

Redistribution configures the protocol from which the routes have to be redistributed into OSPF.

Execute the following commands to configure redistribution.

Type the following:

  • Enter the Global Configuration Mode in ISS1.
iS5comm# configure terminal
  • Enable OSPF globally in the switch ISS1.
iS5comm(config)# router ospf
  • Configure the OSPF router-id.
iS5comm(config-router)# router-id 10.10.2.1
  • Configure the ASBR router.
iS5comm(config-router)# asbr router
  • Configure redistribution of all routes.
iS5comm(config-router)# redistribute all
Note:

Disable redistribution of routes by executing the following command.

iS5comm(config-router)# no redistribute all
Figure 1. Topology for Configuration of Stub area, ASBR and route redistribution


Sample Configuration for Stub area, ASBR, and route redistribution

Some prerequisite configuration (refer Configuration Guidelines (Prerequisite)) must be done in the switches ISS4, ISS5, and ISS7 before configuring OSPF.

  1. Execute the following commands in ISS4, ISS5 and ISS7.

    Type the following:

    Configuration of ISS4

    ISS4 is configured as an ASBR (Autonomous System Border Router) for redistributing the external routes into OSPF domain.

    iS5comm# configure terminal
    iS5comm(config)# router ospf
    iS5comm(config-router)# router-id 10.4.0.4
    iS5comm(config-router)# asbr router 
    iS5comm(config-router)# redistribute all
    iS5comm(config-router)# network 10.5.5.4 area 0.0.0.0
    iS5comm(config-router)# exit
    iS5comm(config)# ip route 100.0.0.0 255.0.0.0 10.5.5.5
    iS5comm(config)# end

    Configuration of ISS7

    In ISS7, area 0.0.0.4 is configured as a stub area. External routes are not redistributed into the stub area.
    iS5comm# configure terminal
    iS5comm(config)# router ospf 
    iS5comm(config-router)# router-id 10.8.0.7
    iS5comm(config-router)# network 10.8.0.7 area 0.0.0.4
    iS5comm(config-router)# area 0.0.0.4 stub
    iS5comm(config-router)# exit
  2. View the configuration details by executing the following show commands.

    Type the following:

    In ISS4

    iS5comm# show ip ospf route
    OSPF Process Routing Table
    Dest/Mask	TOS 	NextHop/Interface 	Cost Rt.Type	Area
    ---------	---	-------/--------- 	---- ------- 	----
    10.5.5.0/255.255.255.0  0   0.0.0.0/vlan4     1	IntraArea 0.0.0.0
    10.8.0.0/255.255.0.0    0   10.5.5.5/vlan4    2	InterArea 0.0.0.0

    iS5comm# show ip ospf 0.0.0.0 database external
    OSPF Router with ID (10.4.0.4)AS External Link States
    -----------------------
    LS age             : 300
    Options LS: (No ToS Capability, DC)
    Type: AS External Link
    Link State ID: 10.5.5.0
    LS Seq Number      : 0x80000001
    Checksum : 0x2a6
    Length             : 36
    Network Mask       : 255.255.0.0
    Metric Type       : 0x80
    Metric            : 10
    Forward Address   : 0.0.0.0
    Externel Route Tag: 0
    AS External Link States
    ----------------------
    
    
    Advertising Router     : 10.4.0.4 
    LS Seq Number          :0x80000001
    Checksum               : 0xbee3
    Length                 : 36
    Network Mask           : 255.255.255.0 
    Metric Type            : 0x80
    Metric                 : 10
    Forward Address: 0.0.0.0 
    Externel Route Tag: 0
    AS External Link States
    -----------------------
    LS age	: 300
    Options	: (No ToS Capability, DC)
    LS Type	: AS External Link
    Link State ID	: 10.5.6.0 
    Advertising Router 	: 10.4.0.4 
    LS Seq Number	: 0x80000001 
    Checksum	: 0xb3ed
    Length	: 36
    Network Mask	:255.255.255.0 
    Metric Type	: 0x80
    Metric	: 10
    Forward Address	: 0.0.0.0
    Externel Route Tag: 0
    AS External Link States
    -----------------------
    LS age:   300
    Options:  (No ToS Capability, DC)
    LS Type:  AS External Link
    Link State ID: 100.0.0.0
    Advertising Router: 10.4.0.4
    LS Seq Number Checksum: 0x80000001
    Advertising Router : 0xcd6b
    Length: 36 
    Network Mask: 255.0.0.0
    Metric Type     : 0x80
    Metric          : 10
    Forward Address : 10.5.5.5 Externel Route Tag: 0

    In ISS5

    View the external routes are redistributed in this switch

    iS5comm# show ip ospf route
    OSPF Process Routing Table 
    Dest/Mask			TOS 	NextHop/Interface	   Cost 	Rt.Type 	Area
    ---------			--- 	-------/---------	    ---- 	-------	----
    10.4.0.0/255.255.0.0	 0	 10.5.5.4/vlan4	 10	 Type2Ext	 0.0.0.0
    10.5.5.0/255.255.255.0	 0	 0.0.0.0/vlan4	 1 	IntraArea	 0.0.0.0
    10.5.6.0/255.255.255.0 	0	 10.5.5.4/vlan4 	10 	Type2Ext	 0.0.0.0
    10.8.0.0/255.255.0.0	 0	 0.0.0.0/vlan1 1	 IntraArea	 0.0.0.4
    100.0.0.0/255.0.0.0	 0	 10.5.5.5/vlan4	 10	 Type2Ext		 0.0.0.0
    iS5comm# show ip ospf 0.0.0.0 database external
    OSPF Router with ID (10.8.0.5)
    AS External Link States
    LS age:   300
    Options:  (No ToS Capability, DC)
    LS Type:  AS External Link
    Link State ID: 10.4.0.0 
    Advertising Router : 10.4.0.4 LS Seq Number	: 0x80000001 Checksum	: 0x2a6
    Length	: 36
    Network Mask	: 255.255.0.0 
    Metric Type	: 0x80
    Metric	: 10
    Forward Address	: 0.0.0.0
    Externel Route Tag: 	0
    AS External Link States
    -----------------------
    LS age	: 300
    Options	: (No ToS Capability, DC)
    LS Type	: AS External Link
    Link State ID	: 10.5.5.0 
    Advertising Router 	: 10.4.0.4 
    LS Seq Number	: 0x80000001 Checksum	: 0xbee3
    Length	: 36
    Network Mask	: 255.255.255.0 
    Metric Type	: 0x80
    Metric	: 10
    Forward Address	: 0.0.0.0 
    Externel Route Tag	: 0
    AS External Link States
    -----------------------
    LS age	: 300
    Options	: (No ToS Capability, DC)
    LS Type	: AS External Link
    Link State ID	: 10.5.6.0 
    Advertising Router 	: 10.4.0.4 
    LS Seq Number	: 0x80000001
    Checksum	: 0xb3ed
    Length	: 36
    Network Mask	: 255.255.255.0 
    Metric Type	: 0x80
    Metric	: 10
    Forward Address	: 0.0.0.0 
    External Route Tag	: 0

    In ISS7

    View the external routes are redistributed in this switch

    iS5comm# show ip ospf route
    OSPF Process Routing Table Dest/Mask		TOS	NextHop/Interface		Cost	Rt.Type	Area
    ---------		---	-------/---------		----	-------	----
    0.0.0.0/0.0.0.0	 0	 10.8.0.5/vlan1	 2	 InterArea 	0.0.0.4
    10.5.5.0/255.255.255.0	 0	 10.8.0.5/vlan1	 2	 InterArea	 0.0.0.4
    10.8.0.0/255.255.0.0	 0	 0.0.0.0/vlan1	 1	 IntraArea	 0.0.0.4
    iS5comm# show ip ospf 0.0.0.4 database external
    OSPF Router with ID (10.8.0.7)

Configuring NSSA Area

An NSSA area has the capability to import limited number of external routes. Execute the following commands to configure an area as an NSSA (Not-So-Stubby-Area) area.

Execute the following commands to configure an area as an NSSA area.

Type the following:

  • Enter the Global Configuration Mode in ISS1.
iS5comm# configure terminal
  • Enable OSPF globally in the switch ISS1.
iS5comm(config)# router ospf
  • Configure the OSPF router-id
iS5comm(config-router)# router-id 10.10.2.1
  • Configure the OSPF interface.
iS5comm(config-router)# network 10.4.0.1 area 0.0.0.0
iS5comm(config-router)# network 10.10.2.1 area 0.0.0.6
  • Configure the area 0.0.0.6 as a NSSA area.
iS5comm(config-router)# area 0.0.0.6 nssa
Note:

Execute the following command to reconfigure the area 0.0.0.6 as a normal area

iS5comm(config-router)# no area 0.0.0.6 nssa
  • Exit from the Interface Configuration mode.
iS5comm(config-if)# end
Note:

Refer to Sample NSSA Configuration, summary address configuration, and area-default cost.

Configuring Summary Address

Execute the following commands to configure a summary address.

Type the following:

  • Enter the Global Configuration Mode in ISS1.
iS5comm# configure terminal
  • Enable OSPF globally in the switch ISS1.
iS5comm(config)# router ospf
  • Configure the OSPF router-id.
iS5comm(config-router)# router-id 10.10.2.1
  • Configure the OSPF interface.
iS5comm(config-router)# network 10.4.0.1 area 0.0.0.0
iS5comm(config-router)# network 10.10.2.1 area 0.0.0.6
  • Configure the area 0.0.0.6 as a NSSA area.
iS5comm(config-router)# area 0.0.0.6 nssa
  • Configure the summary address for 90.0.0.0/8 in the NSSA area.
iS5comm(config-router)# summary-address 90.0.0.0  255.0.0.0 0.0.0.6
Note:

Delete the summary address configuration for 90.0.0.0/8 in the NSSA area by executing the following command

iS5comm(config-router)# no summary-address 90.0.0.0  255.0.0.0 0.0.0.6
  • Exit from the Interface Configuration mode.
iS5comm(config-if)# end

Configuring Area-default Cost

Configuring Area-default Cost specifies the cost for the default summary route sent into a stub or NSSA.

Execute the following commands to configure the Area-default Cost.

Type the following:

  • Enter the Global Configuration Mode in ISS1.
iS5comm# configure terminal
  • Enable OSPF globally in the switch ISS1.
iS5comm(config)# router ospf
  • Configure the OSPF router-id.
iS5comm(config-router)# router-id 10.10.2.1
  • Configure the OSPF interface.
iS5comm(config-router)# network 10.4.0.1 area 0.0.0.0
iS5comm(config-router)# network 10.10.2.1 area 0.0.0.6
  • Configure the area 0.0.0.6 as a NSSA area.
iS5comm(config-router)# area 0.0.0.6 nssa
  • iS5comm(config-router)# area 0.0.0.6 default-cost 50.
iS5comm(config-router)# area 0.0.0.6 default-cost 50
Note:

Go back to default cost for the default summary route sent into NSSA area by executing the following command.

iS5comm(config-router)# no area 0.0.0.6 default-cost
  • Exit from the Interface Configuration mode.
iS5comm(config-if)# end

Sample NSSA Configuration, summary address configuration and area- default cost

Figure 2. Sample NSSA Configuration, summary address configuration and area- default cost


Configuring ISS2, ISS4 and ISS9

Some prerequisite configuration (refer to section 3.2 Configuration Guidelines (Prerequisite)) must be done in the switches ISS2, ISS4, ISS9 before configuring OSPF.

Execute the following commands in ISS2, ISS4 and ISS9.

Type the following:

Configuration of ISS2

ISS4 is configured as an ASBR (Autonomous System Border Router) for redistributing the external routes into OSPF domain.

iS5comm# configure terminal
iS5comm(config)# router ospf
iS5comm(config-router)# router-id 10.4.0.4
iS5comm(config-router)# network 10.4.0.2 area 0.0.0.0 
iS5comm(config-router)# network 10.2.2.2 area 0.0.0.2
  • Configure the area 0.0.0.2 as a NSSA area.
iS5comm(config-router)# area 0.0.0.2 nssa 
iS5comm(config-router)# end

Configuration of ISS4

iS5comm# configure terminal
iS5comm(config)# router ospf
iS5comm(config-router)# router-id 10.4.0.4
iS5comm(config-router)# network 10.4.0.4 area 0.0.0.0
iS5comm(config-router)# end

Configuration of ISS9

iS5comm# configure terminal
iS5comm(config)# router ospf
  • Configure ASBR status and redistribute static routes into the OSPF domain.
iS5comm(config-router)# asbr router 
iS5comm(config-router)# redistribute static 
iS5comm(config-router)# router-id 10.2.2.9
iS5comm(config-router)# network 10.2.2.9 area 0.0.0.2
  • Configure the area 0.0.0.2 as an NSSA area.
iS5comm(config-router)# area 0.0.0.2 nssa
  • Configure summary address for the range 90.0.0.0/8 in the area 0.0.0.2.
iS5comm(config-router)# summary-address 90.0.0.0  255.0.0.0 0.0.0.2
iS5comm(config-router)# exit
  • Configure static routes.
iS5comm(config)# ip route 90.1.0.0	255.255.0.0	10.2.2.2
iS5comm(config)# ip route 90.2.0.0	255.255.0.0	10.2.2.2
iS5comm(config)# ip route 90.3.0.0	255.255.0.0	10.2.2.2
iS5comm(config)# ip route 90.4.0.0	255.255.0.0	10.2.2.2
iS5comm(config)# ip route 90.5.0.0	255.255.0.0	10.2.2.2
iS5comm(config-router)# end

Viewing the configuration details of ISS2, ISS4, and ISS9

Execute the following commands in ISS2, ISS4 and ISS9.

Type the following:

In ISS2

View the two NSSA-external LSAs, one for 90.0.0.0/8 matching the summary range configured and the other for the default external route in the NSSA area.

Another external LSA is generated in the area 0.0.0.0 corresponding to the NSSA-external LSA 90.0.0.0/8.

iS5comm# show ip ospf database nssa-external
OSPF Router with ID (10.4.0.2)
---------------------------------------------
LS age	: 300
Options	: (No ToS Capability, DC)
NSSA External Link States (Area 0.0.0.2)
LS Type	: NSSA External Link
Link State ID	: 90.0.0.0 
Advertising Router 	: 10.2.2.9 
LS Seq Number	: 0x80000001 
Checksum	: 0xc84f 
Length	: 36
NSSA External Link States (Area 0.0.0.2)
LS age	: 300
Options	: (No ToS Capability, DC)
LS Type	: AS External Link
Link State ID	: 0.0.0.0
Advertising Router : 10.4.0.2
LS Seq Number	: 0x80000002 
Checksum	: 0x120
Length	: 36
iS5comm# show ip ospf database external
OSPF Router with ID (10.4.0.2)
AS External Link States
---------------------------------------------
LS age: 0
Options:  (No ToS Capability, DC)
LS Type:  AS External Link
Link State ID: 90.0.0.0
Advertising Router 	: 10.4.0.2 
LS Seq Number	: 0x80000001 
Checksum	: 0x49fd
Length	: 36
Network Mask	: 255.0.0.0 
Metric Type	: 0x80
Metric	: 10
Forward Address	: 10.2.2.9
External Route Tag: 0
iS5comm# show ip ospf route
OSPF Process Routing Table 
Dest/Mask			 TOS 	NextHop/Interface	   Cost 	Rt.Type 	Area
---------			--- 	-------/---------	    ---- 	-------	----
10.2.2.0/255.255.255.0 	0	 0.0.0.0/vlan2 	1	 IntraArea	 0.0.0.2
10.4.0.0/255.255.0.0	 0	 0.0.0.0/vlan1 	1	 IntraArea	 0.0.0.0
90.0.0.0/255.0.0.0 	0	 10.2.2.9/vlan2	 10	 Type2 Ext	0.0.0.2

In ISS4

iS5comm# show ip ospf route
OSPF Process Routing Table 
Dest/Mask			 TOS 	NextHop/Interface	   Cost 	Rt.Type 	Area
---------			--- 	-------/---------	    ---- 	-------	----
10.2.2.0/255.255.255.0 0 	10.4.0.2/vlan1	 2 InterArea 0.0.0.0	10.4.0.0/255.255.0.0 0	 0.0.0.0/vlan1	 1 IntraArea 0.0.0.0
90.0.0.0/255.0.0.0 0 	10.4.0.2/vlan1	 10 Type2Ext 	0.0.0.0

In ISS4

iS5comm# show ip ospf database nssa-external
OSPF Router with ID (10.2.2.9)
NSSA External Link States (Area 0.0.0.2)
---------------------------------------------
LS age: 300
Options:  (No ToS Capability, DC)
LS Type: NSSA External Link
Link State ID: 90.0.0.0
Advertising Router 	: 10.2.2.9
Advertising Router 	: 10.2.2.9 
LS Seq Number	: 0x80000001
Checksum	: 0xc84f
Length	: 36
NSSA External Link States (Area 0.0.0.2)
---------------------------------------------
LS age	: 300
Options	: (No ToS Capability, DC)
LS Type	: NSSA External Link
Link State ID	: 0.0.0.0 
Advertising Router 	: 10.4.0.2 
LS Seq Number	: 0x80000002 
Checksum	: 0x120 
Length	: 36
iS5comm# show ip ospf summary-address
Display of Summary addresses for Type5 and Type7 from redistributed routes
OSPF External Summary Address Configuration Information
-----------------------------------------------------
Network		 Mask 		Area 		Effect 	TranslationState
-------		----		----		------	---------------
90.0.0.0 255.0.0.0 0.0.0.2 	advertiseMatching enabled
iS5comm# show ip route
O 0.0.0.0/0		[2] via 10.2.2.2
C 10.2.2.0/24	is directly connected, vlan2
O 10.4.0.0/16 	[2] via 10.2.2.2
90.0.0.0 255.0.0.0 0.0.0.2	 advertiseMatching enabled
C 12.0.0.0/8 is directly connected, vlan1
S	90.1.0.0/16	[1]	via	10.2.2.2
S	90.2.0.0/16	[1]	via	10.2.2.2
S	90.3.0.0/16	[1]	via	10.2.2.2
S	90.4.0.0/16	[1]	via	10.2.2.2
S	90.5.0.0/16	[1]	via	10.2.2.2
iS5comm# show ip ospf route
iS5comm# show ip ospf route
OSPF Process Routing Table
Dest/Mask		TOS  NextHop/Interface	Cost	Rt.Type		Area
--------		---	-------/---------	----	-------		----
0.0.0.0/0.0.0.0 0	 10.2.2.2/vlan2	 2	 Type1Ext	 0.0.0.2
10.2.2.0/255.255.255.0 	0	 0.0.0.0/vlan2 	1	 IntraArea 	0.0.0.210.4.0.0/255.255.0.0 0	 10.2.2.2/vlan2 	2 	InterArea	0.0.0.2

Testing of ISS2, ISS4 and ISS9

  1. Note: Test ISS9
    Test “no summary- address” command.

    Type the following:

    iS5comm# configure terminal
    iS5comm(config)# router ospf
    iS5comm(config)# ip route 90.5.0.0	255.255.0.0	10.2.2.2
  2. View the configuration detail in ISS9.

    Type the following

    iS5comm# show ip ospf summary-address
    Display of Summary addresses for Type5 and Type7 from redistributed routes
  3. Observe that nssa-external LSA is generated for all static routes

    Type the following

    iS5comm# iS5comm# show ip ospf database
    OSPF Router with ID (10.2.2.9)
    Router Link States (Area 0.0.0.2)
    ---------------------------------------
    Link ID	ADV Router	Age	Seq#	Checksum	Link count
    -------	----------	---	----	--------	----------
    10.4.0.2 	10.4.0.2 	300	 0x80000006	 0x1dc6	 1
    
    
    10.2.2.9	10.2.2.9	300	0x80000007	0xec0	1
    Network Link States (Area 0.0.0.2)
    ---------------------------------------
    
    
    Link ID	ADV Router	Age	Seq#	Checksum
    -------	----------	---	----	--------
    10.2.2.9	10.2.2.9	300	0x80000002	0x5290
    Summary Link States (Area 0.0.0.2)
    -------------------------------------
    
    
    Link ID	ADV Router	Age	Seq#	Checksum
    -------	----------	---	----	--------
    10.4.0.0	10.4.0.2	300	0x80000003	0x56c5
    NSSA External Link States (Area 0.0.0.2)
    ----------------------------------------
    Link ID	ADV Router	Age	Seq#	Checksum
    -------	----------	---	----	--------
    90.4.0.0 	10.2.2.9 	300	 0x80000001	 0x36e4
    90.5.0.0	 10.2.2.9	 300	 0x80000001 	0x2aef
    0.0.0.0 	10.4.0.2 	300 	0x80000003 	0xfe21
    90.1.0.0 	10.2.2.9 	300	 0x80000001 	0x5ac3
    90.2.0.0 	10.2.2.9	 300	 0x80000001 	0x4ece
    90.3.0.0	 10.2.2.9	 300	 0x80000001 	0x42d9
  4. Note: Test ISS2
    View the OSPF external routes corresponding to all NSSA-external LSAs.

    Type the following:

    iS5comm# show ip ospf route
    OSPF Process Routing Table
    Dest/Mask 	TOS	 NextHop/Interface 	Cost	 Rt.Type		 Area
    ---------	---	-------/---------	----	-------		---- 
    10.2.2.0/255.255.255.0 	0	 0.0.0.0/vlan2	1 IntraArea 0.0.0.2
    
    
    10.4.0.0/255.255.0.0    0 0.0.0.0/vlan1	1 IntraArea 0.0.0.0
    
    
    90.1.0.0/255.255.0.0 0	 10.2.2.2/vlan2	10 Type2Ext 0.0.0.2
    
    
    90.2.0.0/255.255.0.0    0	 10.2.2.2/vlan2	10 Type2Ext 0.0.0.2
    
    
    90.3.0.0/255.255.0.0    0	 10.2.2.2/vlan2	10 Type2Ext 0.0.0.2
    
    
    90.4.0.0/255.255.0.0    0	 10.2.2.2/vlan2	10 Type2Ext 0.0.0.2
    
    
    90.5.0.0/255.255.0.0    0	 10.2.2.2/vlan2	10 Type2Ext 0.0.0.2
  5. Test the area default-cost command.

    Type the following:

    iS5comm# configure terminal
    iS5comm(config)# router ospf
    iS5comm(config-router)# area 0.0.0.2 default-cost 50

    Test ISS9

  6. Note:

    ISS2 sends a type 7 LSA for the default route with the updated metric as 50. Therefore, the metric for the default route should be 51 in ISS9.

    In ISS9, view the configuration.

    Type the following:

    iS5comm# show ip ospf route
    Dest/Mask		 TOS	 NextHop/Interface	  Cost 		Rt.Type 	Area
    ---------		--	-------/---------	   ----	-------	----
    0.0.0.0/0.0.0.0         0	 10.2.2.2/vlan2	 51	 Type1Ext 	0.0.0.2
    10.2.2.0/255.255.255.0 	0	 0.0.0.0/vlan2	 1	 IntraArea	 0.0.0.2
    10.4.0.0/255.255.0.0 	0	 10.2.2.2/vlan2 2	 InterArea 	0.0.0.2
  7. in ISS2, test the “no area default-cost” command.

    Type the following:

    iS5comm# configure terminal
    iS5comm(config)# router ospf
    iS5comm(config-router)# no area 0.0.0.2 default-cost 

    IN ISS9

  8. Note:

    ISS2 must have sent a type 7 LSA for the default route with the updated default metric as 10. Therefore, the metric for the default route must be 11 in ISS9.

    In ISS9, view the configuration.

    Type the following:

    iS5comm# show ip ospf route
    Dest/Mask		 TOS	 NextHop/Interface	  Cost 		Rt.Type 	Area
    ---------		--	-------/---------	   ----	-------	----
    0.0.0.0/0.0.0.0         0	 10.2.2.2/vlan2	 11	 Type1Ext 	0.0.0.2
    10.2.2.0/255.255.255.0 	0	 0.0.0.0/vlan2	 1	 IntraArea	 0.0.0.2
    10.4.0.0/255.255.0.0 	0	 10.2.2.2/vlan2 2	 InterArea 	0.0.0.2

Configuring NSSA asbr-default-route translator

Configuring NSSA asbr-default-route translator enables/disables setting of P bit in the default Type-7 LSA generated by NSSA internal ASBR.

Execute the following commands to configure the NSSA asbr-default-route translator.

Type the following:

  • Enter the Global Configuration Mode in ISS1.
iS5comm# configure terminal
  • Enable OSPF globally in the switch ISS1.
iS5comm(config)# router ospf
  • Configure the OSPF router-id.
iS5comm(config-router)# router-id 10.10.2.1
  • Configure the OSPF interface.
iS5comm(config-router)# network 10.10.2.1 area 0.0.0.6
  • Configure the area 0.0.0.6 as a NSSA area.
iS5comm(config-router)# area 0.0.0.6 nssa
  • Enable nssa asbr-default-route translator.
iS5comm(config-router)# set nssa asbr-default-route translator enable
Note:

Disable nssa asbr-default-route translator by executing the following command

iS5comm(config-router)# set nssa asbr-default-route translator disable
  • Exit from the Interface Configuration mode.
iS5comm(config-if)# end

Configuring NSSA Area Translation Role

Configuring NSSA Area Translation Role configures the translation role for the NSSA as always or candidate.

Execute the following commands to configure the NSSA asbr-default-route translator.

Type the following:

  • Enter the Global Configuration Mode in ISS1.
iS5comm# configure terminal
  • Enable OSPF globally in the switch ISS1.
iS5comm(config)# router ospf
  • Configure the OSPF router-id.
iS5comm(config-router)# router-id 10.10.2.1
  • Configure the OSPF interface.
iS5comm(config-router)# network 10.10.2.1 area 0.0.0.6
  • Configure the area 0.0.0.6 as a NSSA area.
iS5comm(config-router)# area 0.0.0.6 nssa
  • Enable nssa asbr-default-route translator.
iS5comm(config-router)# set nssa asbr-default-route translator enable
Note:

Disable nssa asbr-default-route translator by executing the following command

iS5comm(config-router)# set nssa asbr-default-route translator disable
  • Exit from the Interface Configuration mode.
iS5comm(config-if)# end

Configuring Stability Interval for NSSA

This section configures the number of seconds after which an elected translator determines that its services are no longer required, and that it must continue to perform its translation duties for NSSA.

Execute the following commands to configure the stability Interval for NSSA.

Type the following:

  • Enter the Global Configuration Mode in ISS1.
iS5comm# configure terminal
  • Enable OSPF globally in the switch ISS1.
iS5comm(config)# router ospf
  • Configure the OSPF router-id.
iS5comm(config-router)# router-id 10.10.2.1
  • Configure the ASBR router status.
iS5comm(config-router)# asbr router
  • Configure the OSPF interface.
iS5comm(config-router)# network 10.10.2.1 area 0.0.0.6
  • Configure the area 0.0.0.6 as a NSSA area.
iS5comm(config-router)# area 0.0.0.6 nssa
  • Configure the stability interval for the NSSA area 0.0.0.6 as 120 seconds.
iS5comm(config-router)# area 0.0.0.6 stability-interval 120
Note:

Go back to the default stability interval for the NSSA area 0.0.0.6 by executing the following command.

iS5comm(config-router)# no area 0.0.0.6 stability-interval
Note:

The default value for stability interval is 40 seconds and is configured using the command no area <area-id> stability-interval.

  • Exit from the Interface Configuration mode.
iS5comm(config-if)# end

Configuring ABR-Type

Configuring abr-type sets the ABR-Type as either standard, or Cisco, or IBM.

  1. Execute the following commands to configure the abr-type.

    Type the following:

    • Enter the Global Configuration Mode in ISS1.
    iS5comm# configure terminal
    • Enable OSPF globally in the switch ISS1.
    iS5comm(config)# router ospf
    • Configure the OSPF router-id
    iS5comm(config-router)# router-id 10.10.2.1
    • Configure the OSPF interface.
    iS5comm(config-router)# network 10.4.0.1 area 0.0.0.0
    iS5comm(config-router)# network 10.10.2.1 area 0.0.0.6
    • Configure the ABR type as Cisco.
    iS5comm(config-router)# abr-type cisco
    Note:

    The default value ABR type is standard.

    • Exit from the Router Configuration mode.
    iS5comm(config-router)# end
  2. View the configuration details by executing the following show command.

    Type the following:

    iS5comm# show ip ospf
    OSPF Router ID 10.10.2.1
    Supports only single TOS(TOS0) route
    ABR Type supported is Cisco ABR
    It is an Area Border Router
    Number of Areas in this router is 2 Area is 0.0.0.6
    Number of interfaces in this area is 1 
    SPF algorithm executed 3 times
    Area is 0.0.0.0
    Number of interfaces in this area is 1 
    SPF algorithm executed 3 times

Configuring RFC 1583 Compatibility

Configuring RFC 1583 Compatibility sets the OSPF compatibility list to be compatible with the RFC 1583.

Execute the following commands to configure the RFC 1583 Compatibility.

Type the following:

  • Enter the Global Configuration Mode in ISS1.
iS5comm# configure terminal
  • Enable OSPF globally in the switch ISS1.
iS5comm(config)# router ospf
  • Configure the OSPF router-id.
iS5comm(config-router)# router-id 10.10.2.1
  • Configure the OSPF interface.
iS5comm(config-router)# network 10.4.0.1 area 0.0.0.0
iS5comm(config-router)# network 10.10.2.1 area 0.0.0.6
  • Configure the RFC1583 compatibility.
iS5comm(config-router)# compatible rfc1583
Note: Disable RFC 1583 compatibility by executing the following command.
iS5comm(config-router)# no compatible rfc1583

Generation of a Default External Route

Configuring Default-information Originate Always enables generation of a default external route into the OSPF routing domain and other parameters related to that area.

Execute the following commands to configure the Default-information Originate Always.

Type the following:

  • Enter the Global Configuration Mode in ISS1.
iS5comm# configure terminal
  • Enable OSPF globally in the switch ISS1.
iS5comm(config)# router ospf
  • Configure the OSPF router-id.
iS5comm(config-router)# router-id 10.10.2.1
  • Configure the OSPF interface.
iS5comm(config-router)# network 10.4.0.1 area 0.0.0.0
iS5comm(config-router)# network 10.10.2.1 area 0.0.0.6
  • Configure the ASBR router status.
iS5comm(config-router)# asbr router
  • Configure the generation of a default external route.
iS5comm(config-router)# default-information originate always metric 40
Note:

Disable generation of a default external route by executing the following command.

iS5comm(config-router)# no default-information originate always
Note:

Refer to Figure Topology for Testing Generation of a Default External Route and Redistribution Configuration.

Configuring Redistribution Configuration

Configuring redistribution configuration configures the information to be applied to routes learnt from RTM.

Execute the following commands to configure Redistribution.

Type the following:

  • Enter the Global Configuration Mode in ISS1.
iS5comm# configure terminal
  • Enable OSPF globally in the switch ISS1.
iS5comm(config)# router ospf
  • Configure the OSPF router-id.
iS5comm(config-router)# router-id 10.10.2.1
  • Configure the ASBR router.
iS5comm(config-router)# asbr router
  • Configure the redistribution of static routes.
iS5comm(config-router)# redistribute static
  • Configure the redistribution configuration.
iS5comm(config-router)# redist-config 20.0.0.0 255.0.0.0 metric-value 100 metric-type asExttype1 tag 10
Note:

Delete the information applied to the routes learnt from RTM by executing the following command

iS5comm(config-router)# no redist-config 20.0.0.0 255.0.0.0
Figure 3. Topology for Testing Generation of a Default External Route and Redistribution


Sample Configuration for testing default-information originate always and redist-config.

Some prerequisite configuration (refer to Section Configuration Guidelines (Prerequisite)) must be done in the switches ISS1 & ISS2 before configuring OSPF.

Configuration of ISS1

Execute the following commands in ISS1 to configure the generation of a default external route.

Type the following:

  • Enter the Global Configuration Mode in ISS1.
iS5comm# configure terminal
  • Enable OSPF globally in the switch ISS1.
iS5comm(config)# router ospf
  • Configure the OSPF router-id.
iS5comm(config-router)# router-id 10.10.2.1
  • Configure the OSPF interface.
iS5comm(config-router)# network 10.4.0.1 area 0.0.0.0
iS5comm(config-router)# network 10.10.2.1 area 0.0.0.6
  • Configure the ASBR router.
iS5comm(config-router)# asbr router
  • Configure the generation of a default external route.
iS5comm(config-router)# default-information originate always metric 40
  • Exit from the Router Configuration mode.
iS5comm(config-router)# end

Configuration of ISS2

  1. Execute the following commands in ISS2.

    Type the following:

    • Enter the Global Configuration Mode in ISS2.
    iS5comm# configure terminal
    • Enable OSPF globally in the switch ISS2
    iS5comm(config)# router ospf
    • Configure the OSPF router-id.
    iS5comm(config-router)# router-id 10.4.0.2
    • Configure the OSPF interface.
    iS5comm(config-router)# network 10.4.0.2 area 0.0.0.0
    iS5comm(config-router)# network 10.2.2.2 area 0.0.0.2
    • Configure area 0.0.0.2 as an NSSA area.
    iS5comm(config-router)# area 0.0.0.2 nssa
    • Exit from the Router Configuration mode.
    iS5comm(config-router)# end
  2. View the configuration details by executing the following show command in ISS1.

    Type the following:

    iS5comm# show ip ospf database external
    OSPF Router with ID (10.10.2.1)
    AS External Link States
    -----------------------
    LS age	: 0
    Options	: (No ToS Capability, DC)
    LS Type	: AS External Link
    Link State ID: 0.0.0.0
    Advertising Router : 10.10.2.1
    LS Seq Number	: 0x80000001
    Checksum	: 0xb5dd
    Length	: 36
    Network Mask	: 0.0.0.0 
    Metric Type	: 0x80
    Metric	: 40
    Forward Address	: 0.0.0.0 
    Externel Route Tag	: 0
  3. View the configuration details by executing the following show command in ISS2.

    Type the following:

    iS5comm# show ip ospf route
    OSPF Process Routing Table
     	Dest/Mask	  TOS	NextHop/Interface		Cost	Rt.Type		Area
    ---------	  ---	-------/---------		----	-------		----
    0.0.0.0/0.0.0.0   0	 10.4.0.1/vlan1	 40 Type2Ext 	0.0.0.0	
    
    
    10.2.2.0/255.255.255.0 0	 0.0.0.0/vlan2	       1 IntraArea       0.0.0.2
    
    
    10.4.0.0/255.255.0.0   0 	0.0.0.0/vlan1	       1 IntraArea       0.0.0.0
    
    
    10.10.0.0/255.255.0.0  0	 10.4.0.1/vlan1	       2 InterArea      0.0.0.0	
  4. Execute the following commands in ISS1 to configure the generation of a default external route.

    Type the following:

    • Enter the Global Configuration Mode in ISS1.
    iS5comm# configure terminal
    • Enable OSPF globally in the switch ISS1.
    iS5comm(config)# router ospf
    • Configure the default external route.
    iS5comm(config-router)# no default-information originate always
    • Exit from the Router Configuration mode.
    iS5comm(config-router)# end
  5. View the configuration details by executing the following show command in ISS1. Type 5 External LSA for the default route must be flushed

    Type the following:

    iS5comm# show ip ospf database external
    OSPF Router with ID (10.10.2.1)
  6. View the configuration details by executing the following show command in ISS2. The route entry for the default route must be deleted.

    Type the following:

    iS5comm# show ip ospf route
    OSPF Process Routing Table
     	Dest/Mask	  TOS	NextHop/Interface		Cost	Rt.Type		Area
    ---------	  ---	-------/---------		----	-------		----
    10.2.2.0/255.255.255.0 0	 0.0.0.0/vlan2	       1 IntraArea       0.0.0.2
    
    
    10.4.0.0/255.255.0.0   0	 0.0.0.0/vlan1	       1 IntraArea       0.0.0.0
    
    
    10.10.0.0/255.255.0.0  0	 10.4.0.1/vlan1	       2 InterArea      0.0.0.0	

  1. Execute the following commands in ISS1 to configure the generation of a default external route.

    Type the following:

    • Enter the Global Configuration Mode in ISS1.
    iS5comm# configure terminal
    • Enable OSPF globally in the switch ISS1.
    iS5comm(config)# router ospf
    • Configure the default external route.
    iS5comm(config-router)# no default-information originate always
    • Exit from the Router Configuration mode.
    iS5comm(config-router)# end
  2. View the configuration details by executing the following show command in ISS1. Type 5 External LSA for the default route must be flushed

    Type the following:

    iS5comm# show ip ospf database external
    OSPF Router with ID (10.10.2.1)
  3. View the configuration details by executing the following show command in ISS2. The route entry for the default route must be deleted.

    Type the following:

    iS5comm# show ip ospf route
    OSPF Process Routing Table
     	Dest/Mask	  TOS	NextHop/Interface		Cost	Rt.Type		Area
    ---------	  ---	-------/---------		----	-------		----
    10.2.2.0/255.255.255.0 0	 0.0.0.0/vlan2	       1 IntraArea       0.0.0.2
    
    
    10.4.0.0/255.255.0.0   0	 0.0.0.0/vlan1	       1 IntraArea       0.0.0.0
    
    
    10.10.0.0/255.255.0.0  0	 10.4.0.1/vlan1	       2 InterArea      0.0.0.0	

Configuration in ISS1

  1. Execute the following commands in ISS1 to test redist-config.

    Type the following:

    • Enter the Global Configuration Mode in ISS1.
    iS5comm# configure terminal
    • Enable OSPF globally in the switch ISS1.
    iS5comm(config)# router ospf
    • Configure redistribution of static routes redist-config.
    iS5comm(config-router)# redistribute static
    • Configure redist-config.
    iS5comm(config-router)# redist-config 20.0.0.0 255.0.0.0 metric-value 100 metric-type asExttype1 tag 10
    iS5comm(config-router)# exit
    • Add a static route for 20.0.0.0/8 network.
    iS5comm(config)# ip route 20.0.0.0 255.0.0.0 10.4.0.2
    • Exit from the Global Configuration mode.
    iS5comm(config)# exit
  2. View the configuration details by executing the following show command in ISS1. An external LSA is generated for 20.0.0.0 with metric as 100, metric type as asExtType1, and tag 10.

    Type the following:

    iS5comm# show ip ospf database external
    OSPF Router with ID (10.10.2.1)
    AS External Link States
    -----------------------
    LS age	: 600
    Options	: (No ToS Capability, DC)
    LS Type	: AS External Link
    Link State ID	: 20.0.0.0 
    Advertising Router 	: 10.10.2.1 
    LS Seq Number	: 0x80000001 
    Checksum	: 0xf6b2
    Length	: 36
    Network Mask	: 255.0.0.0
    Metric Type	: 0x0
    Metric	: 100
    Forward Address	: 10.4.0.2

    In ISS2:

  3. View the external route 20.0.0.0/8 with metric as 101.

    Type the following:

    iS5comm# show ip ospf route
    OSPF Process Routing Table
     	Dest/Mask	  TOS	NextHop/Interface		Cost	Rt.Type		Area
    ---------	  ---	-------/---------		----	-------		----
    10.4.0.0/255.255.255.0 0	 0.0.0.0/vlan1 1 IntraArea       0.0.0.0
    
    
    10.10.0.0/255.255.0.0   0	 0.0.0.0/vlan1	       2 IntraArea       0.0.0.0
    
    
    20.0.0.0/255.0.0.0  0	 10.4.0.2/vlan1	       101 Type1Ext 0.0.0.0	
    
    
    10.2.2.0/255.255.255.0 0	 0.0.0.0/vlan2	       1 IntraArea       0.0.0.2

Configuration in ISS2

  1. Execute the following commands in ISS1 to test no redist-config.

    Type the following:

    • Enter the Global Configuration Mode in ISS1.
    iS5comm# configure terminal
    • Enable OSPF globally in the switch ISS1.
    iS5comm(config)# router ospf
    • Configure no redist-config.
    iS5comm(config-router)# no redist-config 20.0.0.0 255.0.0.0
    • Exit from the Router Configuration mode.
    iS5comm(config-router)# exit
  2. View the configuration details by executing the following show command. The external LSA generated for 20.0.0.0 with metric as 100, metric type as asExtType1, and tag as 10 is flushed and a new external LSA is generated with the default redistribution configuration.

    Type the following:

    iS5comm# show ip ospf database external
    OSPF Router with ID (10.10.2.1)
    AS External Link States
    -----------------------
    LS age	: 0
    Options	: (No ToS Capability, DC)
    LS Type	: AS External Link
    Link State ID	: 20.0.0.0 
    Advertising Router 	: 10.10.2.1 
    LS Seq Number	: 0x80000002 
    Checksum	: 0x3c5
    Length	: 36
    Network Mask	: 255.0.0.0
    Metric Type	: 0x0
    Metric	: 10
    Forward Address	: 10.4.0.2
    Externel Route Tag: 0

Configuring Neighbor

Configuring Neighbor specifies an NBMA (Non Broadcast Multi Access) neighbor router and its priority.

Execute the following commands to configure a Neighbor.

Type the following:

  • Enter the Global Configuration Mode in ISS1.
iS5comm# configure terminal
  • Enable OSPF globally in the switch ISS1.
iS5comm(config)# router ospf
  • Configure the OSPF router-id
iS5comm(config-router)# router-id 10.10.2.1
  • Configure the OSPF interface.
iS5comm(config-router)# network 10.4.0.1 area 0.0.0.0
iS5comm(config-router)# network 10.10.2.1 area 0.0.0.6
  • Exit from the Router Configuration mode.
iS5comm(config-router)# end
  • Enter the Interface Configuration mode.
iS5comm(config-if)# interface vlan 1
  • Configure the network type as NBMA.
iS5comm(config-if)# ip ospf network non-broadcast
  • Configure the neighbor with priority.
iS5comm(config-if)# exit 
iS5comm(config)# router ospf
iS5comm(config-router)# neighbor 10.4.0.2 priority 10
  • Configure the neighbor with default priority.
iS5comm(config-if)# no neighbor 10.4.0.2 priority 10
Note:

Delete the configured neighbor by executing the following command.

iS5comm(config-router)# no neighbor 10.4.0.2

Configuring Virtual Link

Configuring Virtual Link defines an OSPF virtual link and its related parameters.

Execute the following commands to configure the Virtual Link.

Type the following:

  • Enter the Global Configuration Mode in ISS1.
iS5comm# configure terminal
  • Enable OSPF globally in the switch ISS1.
iS5comm(config)# router ospf
  • Configure the OSPF router-id.
iS5comm(config-router)# router-id 10.10.2.1
  • Configure the OSPF interface.
iS5comm(config-router)# network 10.4.0.1 area 0.0.0.0
iS5comm(config-router)# network 10.10.2.1 area 0.0.0.6
  • Configure the virtual link.
iS5comm(config-router)# area 0.0.0.6 virtual-link 20.0.0.1 authentication message-digest hello-interval 100 retransmit-interval 100 transmit-delay 50 dead-interval 200 authentication-key asdf
Note: Delete the virtual link by executing the following command.
iS5comm(config-router)# no area 0.0.0.6 virtual-link 20.0.0.1
Note: Refer to Sample Configuration for testing virtual link and route summarization

Configuring Virtual Link with SHA-1

Configuring Virtual Link defines an OSPF virtual link and its related parameters.

Execute the following commands to configure the Virtual Link.

Type the following:

  • Enter the Global Configuration Mode in ISS1.
iS5comm# configure terminal
  • Enable OSPF globally in the switch ISS1.
iS5comm(config)# router ospf
  • Configure the OSPF router-id.
iS5comm(config-router)# router-id 10.10.2.1
  • Configure the OSPF interface.
iS5comm(config-router)# network 10.4.0.1 area 0.0.0.0
iS5comm(config-router)# network 10.10.2.1 area 0.0.0.6
  • Configure the virtual link with sha-1. Here, the sha-1 can be replaced by the sha-2 algorithms such as sha-224/ sha-256/ sha-384/ sha-512.
iS5comm(config-router)# area 0.0.0.6 virtual-link 20.0.0.1 authentication sha-1 hello-interval 100 retransmit-interval 100 transmit-delay 50 dead-interval 200 message-digest-key 1 sha-1 abcd
Note: Delete the virtual link by executing the following command.
iS5comm(config-router)# no area 0.0.0.6 virtual-link 20.0.0.1
Note: Refer to Sample Configuration for testing virtual link and route summarization

Configuring Area-range

The area-range is configured to consolidate and summarize routes at an area boundary.

Execute the following commands to configure the route summarization at an area border router.

Type the following:

  • Enter the Global Configuration Mode in ISS1.
iS5comm# configure terminal
  • Enable OSPF globally in the switch ISS1.
iS5comm(config)# router ospf
  • Configure the OSPF router-id.
iS5comm(config-router)# router-id 10.10.2.1
  • Configure the OSPF interface.
iS5comm(config-router)# network 10.4.0.1 area 0.0.0.0
iS5comm(config-router)# network 10.10.2.1 area 0.0.0.6
  • Configure the route summarization at an area border router.
iS5comm(config-router)# area 0.0.0.6 range 10.10.0.0 255.255.0.0 summary
Note: Delete the route summarization information by executing the following command.
iS5comm(config-router)# no area 0.0.0.6 range 10.10.0.0 255.255.0.0