Configuring Route Map – OSPF

iS5Com’s Unified Route Map (URM) is a portable implementation of the route map capability for IPv4 and IPv6 unicast routing software. The URM provides a single interface for the administrator to set up and manage route maps. It also provides a common unified method for routing protocols and static route management software to use route maps for different purposes. The independent nature of the implementation helps to avoid the duplication of the route maps in the different routing modules in a router.

Configuring Route Map

This section lists the CLI configuration steps to define a route map with a specified name and the related parameters such as permission and sequence number.

  1. Execute the following commands to suppress routing updates on all interfaces.

    Type the following:

    • Enter the Global Configuration Mode in ISS1.
    iS5comm# configure terminal
    • Configure the route map name, permission and sequence number.
    iS5comm(config)# route-map aa permit 1
    • Exit from the Global Configuration mode.
    iS5comm(config)# exit
  2. View the configured route map.

    Type the following:

    iS5comm# show route-map
    Route-map aa, Permit, Sequence 1
    Match Clauses:
    --------------
    Set Clauses:
    --------------
  3. Delete the route map configured by executing the following commands.

    Type the following:

    iS5comm(config)# no route-map aa 1

Configuring Route Map Match Criteria

This section lists the CLI configuration steps to define the filtering criteria for the route map and its related parameters.

  1. Execute the following commands to suppress routing updates on all interfaces.

    Type the following:

    • Enter the Global Configuration Mode in ISS1.
    iS5comm# configure terminal
    • Configure the route map name, permission and sequence number.
    iS5comm(config)# route-map aa permit 1
    • Configure the route map match source IP address and the subnet mask.
    iS5comm (config-rmap-aa)# match source ip 34.0.0.3 255.0.0.0
    • Configure the route map match source IPv6 address and the prefix length.
    iS5comm (config-rmap-aa)# match source ipv6 2120::3 64
    • Configure the route map match destination IP address and the subnet mask
    iS5comm (config-rmap-aa)# match destination ip 91.0.0.1 255.0.0.0
    • Configure the route map match destination IPv6 address and prefix length.
    iS5comm (config-rmap-aa)# match destination ipv6 2150::2 64
    • Configure the route map match route-type as remote. (Route-type can be configured either as local or remote.)
    iS5comm (config-rmap-aa)# match route-type remote
    • Configure the route map match metric-type. (Metric type can be inter-area / intra-area / type-1-external / type-2-external.).
    iS5comm (config-rmap-aa)# match metric-type inter-area
    • Configure the route map match metric value.
    iS5comm (config-rmap-aa)# match metric 44
    • Configure the route map match next-hop IP address.
    iS5comm (config-rmap-aa)# match next-hop ip 91.0.0.1.
    • Configure the route map match next-hop IPv6 address.
    iS5comm (config-rmap-aa)# match next-hop ipv6 3000::3
    • Configure the route map match tag.
    iS5comm (config-rmap-aa)# match tag 10
    • Exit from the Route Map Configuration mode.
    iS5comm(config)# exit
  2. View the configured route map.

    Type the following:

    iS5comm# show running-config route-map
    Building configuration...
    route-map aa permit 1
    match destination ip 91.0.0.1  255.0.0.0
    match destination ipv6 2150::2  64
    match source ip 34.0.0.3  255.0.0.0
    match source ipv6 2120::3  64
    match next-hop ip 91.0.0.1
    match next-hop ipv6 3000::3
    match metric 44
    match tag 10
    match metric-type inter-area
    match route-type remote
    end
  3. Execute the no form of the commands to delete the configurations.

Configuring OSPF Distance

This section lists the CLI configuration steps to define a route map with a specified name and the related parameters such as permission and sequence number.

  1. Execute the following commands to suppress routing updates on all interfaces.

    Type the following:

    • Enter the Global Configuration Mode in ISS1.
    iS5comm# configure terminal
    • Enter the OSPF Router Configuration Mode.
    iS5comm(config)# router ospf
    • Configure the distance for the OSPF routes.
    iS5comm(config-router)# distance 130
    • Exit the OSPF Router Configuration Mode.
    iS5comm(config- router)# end
  2. View the configured route map.

    Type the following:

    iS5comm# show running-config ospf
    Building configuration...
    router ospf
    distance 130
    !
    router ospf
    !
    end
  3. Re-configure the distance to its default value..

    Type the following:

    iS5comm(config-router)# no distance

Configuring Redistribution with Route Map

This section lists the CLI configuration steps to define a route map with a specified name and the related parameters such as permission and sequence number.

  1. Execute the following commands to suppress routing updates on all interfaces.

    Type the following:

    • Enter the Global Configuration Mode in ISS1.
    iS5comm# configure terminal
    • Enter the OSPF Router Configuration Mode.
    iS5comm(config)# router ospf
    • Configure the OSPF router ID.
    iS5comm(config)# router-id 10.10.2.1
    • Configure the router as ASBR (Autonomous System Boundary Router).
    iS5comm(config-router)# ASBR Router
    • Configure the redistribution of all routes with route-map aa.
    iS5comm(config-router)# redistribute all route-map aa
    • Exit the OSPF Router Configuration Mode.
    iS5comm(config- router)# end
  2. View the configured route map.

    Type the following:

    iS5comm# show running-config ospf
    Building configuration...
    router ospf 
    router-id 10.10.2.1
    ASBR Router
    redistribute static route-map aa
    redistribute connected route-map aa
    redistribute rip route-map aa
    redistribute bgp route-map aa
    distance 130
    !
    router ospf
    !
    end
  3. Disable the redistribution of all routes with route-map.

    Type the following:

    iS5comm(config-router)# no redistribute all route-map aa

Topology Configuration for OSPF Testing

This section provides the sample configuration for testing a route map with OSPF.

Figure 1. Topology Configuration for OSPF Testing


Table 1. IPv4 / IPv6 Addresses of Interfaces in the Routers – OSPF Testing
Router Interface Ports IPv4 Address / Mask IPv6 Address/ Prefix Length
R1 Vlan 12 Tagged ports E1 12.0.0.1/8 2120::1/24
Vlan 13 Tagged ports E2 13.0.0.1/8 2130::1/24
Vlan 110 Tagged ports E3 70.0.0.1/8 2070::1/24
R2 Vlan 12 Tagged ports E1 12.0.0.2/8 2120::2/24
Vlan 24 Tagged ports E2 24.0.0.2/8 2240::2/24
R3 Vlan 13 Tagged ports E1 13.0.0.3/8 2130::3/24
Vlan 34 Tagged ports E2 34.0.0.3/8 2340::3/24
R4 Vlan 24 Tagged ports E1 24.0.0.4/8 2240::4/24
Vlan 34 Tagged ports E2 34.0.0.4/8 2340::4/24

R1 – ASBR router

All OSPF routers have router-ID 0.0.0.N, where N - number of router.

All OSPF routers use area 0.0.0.0.

Some prerequisite configuration must be done in the switches R1, R2, R3 and R4 before configuring OSPF.

  1. To test the behavior of route selection, when distance command is applied to the OSPF router, execute the following commands in R1, R2, R3, and R4.

    Type the following:

    • R1
    iS5comm# configure terminal 
    iS5comm(config)# router ospf
    iS5comm(config-router)# router-id 0.0.0.1
    iS5comm(config-router)# ASBR Router
    iS5comm(config-router)# network 13.0.0.1 area 0.0.0.0
    iS5comm(config-router)# exit
    iS5comm(config)# router rip
    iS5comm(config-router)# network 12.0.0.1
    iS5comm(config-router)#end
    • R2
    iS5comm# configure terminal
    iS5comm(config)# router rip
    iS5comm(config-router)# network 12.0.0.2
    iS5comm(config-router)# network 24.0.0.2
    iS5comm(config-router)#end
    • R3
    iS5comm# configure terminal 
    iS5comm(config)# router ospf
    iS5comm(config-router)# router-id 0.0.0.2
    iS5comm(config-router)# network 13.0.0.3 area 0.0.0.0
    iS5comm(config-router)# network 34.0.0.3 area 0.0.0.0
    iS5comm(config-router)# end
    • R4
    iS5comm# configure terminal 
    iS5comm(config)# router ospf
    iS5comm(config-router)# router-id 0.0.0.3
    iS5comm(config-router)# network 34.0.0.4 area 0.0.0.0iS5comm(config-router)# exit
    iS5comm(config)# router rip
    iS5comm(config-router)# network 24.0.0.4
    iS5comm(config-router)#end
  2. Configure the route-map aa with match criteria at R4.

    Type the following:

    iS5comm# configure terminal 
    iS5comm(config)# route-map aa permit 1
    iS5comm(config-rmap-aa)# match source ip 34.0.0.3 255.0.0.0
    iS5comm(config-rmap-aa)# exit
  3. Apply redistribute all to RIP and OSPF routers at R4.

    Type the following:

    iS5comm# configure terminal 
    iS5comm(config)# router ospf
    iS5comm(config-router)# redistribute all
    iS5comm(config-router)#end
    iS5comm(config)# router rip
    iS5comm(config-router)# redistribute all
    iS5comm(config-router)#end
    iS5comm(config-rmap-aa)# match source ip 34.0.0.3 255.0.0.0
    iS5comm(config-rmap-aa)# exit
  4. View the routes at R4.

    Type the following:

    iS5comm# show ip route
    Vrf Name:          default
    C 12.0.0.0/8  is directly connected, vlan1
    O 13.0.0.0/8  [2] via 34.0.0.3
    O 15.0.0.0/8  [10] via 34.0.0.3
    C 24.0.0.0/8  is directly connected, vlan24 C 34.0.0.0/8  is directly connected, vlan34
    O 70.0.0.0/8  [10] via 34.0.0.3
  5. Set the administrative distance 130 to the OSPF router in R4.

    Type the following:

    iS5comm# configure terminal
    iS5comm(config)# router ospf
    iS5comm(config-router)# distance 130 route-map aa
    iS5comm(config-router)# exit
  6. Force routes updates in R1.

    Type the following:

    iS5comm# configure terminal
    iS5comm(config)# router ospf
    iS5comm(config-router)# no redistribute all
    iS5comm(config-router)# redistribute all
    iS5comm(config-router)# exit
    iS5comm(config)# router rip
    iS5comm(config-router)# no redistribute all
    iS5comm(config-router)# redistribute all
    iS5comm(config-router)# exit
  7. View the routes at R4.

    Type the following:

    iS5comm# show ip route
    Vrf Name:          default
    C 12.0.0.0/8  is directly connected, vlan1
    O 13.0.0.0/8  [2] via 34.0.0.3
    O 15.0.0.0/8  [10] via 34.0.0.3
    C 24.0.0.0/8  is directly connected, vlan24 C 34.0.0.0/8  is directly connected, vlan34
    R 70.0.0.0/8  [5] via 24.0.0.2
  8. Reset the administrative distance to the OSPF router in R4.

    Type the following:

    iS5comm# configure terminal
    iS5comm(config)# router ospf 
    iS5comm(config-router)# no distance 130 route-map aa
    iS5comm(config-router)# exit
  9. Force routes updates in R1.

    Type the following:

    iS5comm# configure terminal
    iS5comm(config)# router ospf
    iS5comm(config-router)# no redistribute all
    iS5comm(config-router)# redistribute all
    iS5comm(config-router)# exit
    iS5comm(config)# router rip
    iS5comm(config-router)# no redistribute all
    iS5comm(config-router)# redistribute all
    iS5comm(config-router)# exit
  10. View the routes at R4.

    Type the following:

    iS5comm# iS5comm# show ip route
    Vrf Name:          default
    C 12.0.0.0/8  is directly connected, vlan1
    O 13.0.0.0/8  [2] via 34.0.0.3
    O 15.0.0.0/8  [10] via 34.0.0.3
    C 24.0.0.0/8  is directly connected, vlan24 C 34.0.0.0/8  is directly connected, vlan34
    O 70.0.0.0/8  [10] via 34.0.0.3

Redistribution Topology

This section provides the sample configuration for testing redistribution of routes into OSPF with route map.

Figure 2. Redistribution Topology Configurations


Redistribution Interface Configuration

Table 2. IPv4 / IPv6 Addresses of Interfaces in the Routers – Redistribution Topology
Router Interface Ports IPv4 Address / Mask IPv6 Address/ Prefix Length
R1 Vlan 12 Tagged ports E1 140.0.0.1/16 2140::1/24
Vlan 110 Tagged ports E2 70.0.0.1/8 2070::1/24
R2 Vlan 12 Tagged ports E1 140.0.0.2/16 2140::2/24
Vlan 23 Tagged ports E3 20.0.0.2/8 2140::2/24
Vlan 24 Tagged ports E2 60.0.0.2/8 2040::2/24
Vlan 25 Tagged ports E4 40.0.0.2/8 2060::2/24
Vlan 125 Tagged ports E5 50.0.0.2/8 2050::2/24
R3 Vlan 23 Tagged ports E1 13.0.0.3/8 2020::3/24
Vlan 130 Tagged ports E2 34.0.0.3/8 2011::3/24
R5 Vlan 24 Tagged ports E1 24.0.0.4/8 2060::5/24
Vlan 34 Tagged ports E2 34.0.0.4/8 2014::5/24

Protocol Configuration

Table 3. Protocol Configuration
Router Interface
R1

Interface Vlan 12

Enable RIPv2.

R2

Interface Vlan 12

Enable RIPv2.

Interface Vlan 23

Enable OSPFv2 with Area 0. Configure this as the ASBR router.

Enable OSPFv3 with Area 0. Configure this as the ASBR router.

Interface Vlan 25

Enable BGP with peer Vlan 25 interface on R5 with remote AS 300.

R3

Interface Vlan 23Enable OSPFv2 with Area 0.Enable OSPFv3 with Area 0

R5

Interface Vlan 25Enable BGP with peer as VLAN 25 interface on R2 with remote AS 100.

  1. To test the following behaviors, execute the following commands:
    1. redistribution of static routes into OSPFv2 with the route map with <match destination ip> clause
    2. redistribution of static routes into OSPFv2, when the route map is modified or deleted
    3. redistribution of static routes into OSPFv2, when static routes for redistribution are added or deleted.

    Type the following:

    • Configuration at R1
    iS5comm# configure terminal 
    iS5comm(config)# router rip
    iS5comm(config-router)# network 140.0.0.1
    iS5comm(config-router)#end
    • Configuration at R2
    iS5comm# configure terminal
    iS5comm(config)# router rip
    iS5comm(config-router)# network 140.0.0.1
    iS5comm(config-router)# exit
    iS5comm(config)# router ospf
    iS5comm(config-router)# router-id 0.0.0.1
    iS5comm(config-router)# ASBR Router
    iS5comm(config-router)# network 20.0.0.2 area 0.0.0.0
    iS5comm(config-router)# exit
    iS5comm(config)# as-num 100
    iS5comm(config)# router-id 40.0.0.2
    iS5comm(config)# router bgp 100
    iS5comm(config-router)# neighbor 40.0.0.5 remote-as 300
    iS5comm(config-router)#end
    iS5comm# configure terminal 
    iS5comm(config)# router ospf
    iS5comm(config-router)# router-id 0.0.0.3
    iS5comm(config-router)# network 34.0.0.4 area 0.0.0.0
    iS5comm(config-router)# exit
    iS5comm(config)# router rip
    iS5comm(config-router)# network 24.0.0.4
    iS5comm(config-router)#end
    • Configuration at R3
    iS5comm# configure terminal
    iS5comm(config)# router ospf
    iS5comm(config-router)# router-id 0.0.0.2
    iS5comm(config-router)# network 20.0.0.3 area 0.0.0.0
    iS5comm(config-router)# exit
    • Configuration at R5
    iS5comm# configure terminal 
    iS5comm(config)# as-num 300
    iS5comm(config)# router-id 40.0.0.5
    iS5comm(config)# router bgp 300
    iS5comm(config-router)# neighbor 40.0.0.2 remote-as 100iS5comm(config-router)# exit
  2. Perform the following configurations in R2. In R2, create static routes and create a route-map aa

    Type the following:

    iS5comm# configure terminal 
    iS5comm(config)# ip route 91.0.0.0 255.0.0.0 vlan 24
    iS5comm(config)# ip route 92.0.0.0 255.0.0.0 vlan 24
    iS5comm(config)# route-map aa permit 1
    iS5comm(config-rmap-aa)# match destination ip 91.0.0.0 255.0.0.0
    iS5comm(config-rmap-aa)# end
    iS5comm#configure terminal
    iS5comm(config)# route-map aa deny 2
    iS5comm(config-rmap-aa)# match destination ip 93.0.0.0 255.0.0.0
  3. Enable redistribution of static routes into OSPFv2 with route map aa

    Type the following:

    iS5comm# configure terminal 
    iS5comm(config)# router ospf
    iS5comm(config-router)# redistribute static route-map aa
  4. Verify the route in R3, verify 91.0.0.0/8 is present in the general routing table

    Type the following:

    iS5comm# show ip route
    Vrf Name:          default
    C 11.0.0.0/8  is directly connected, vlan130
    C 12.0.0.0/8  is directly connected, vlan1 
    C 20.0.0.0/8  is directly connected, vlan23
    O 91.0.0.0/8  [10] via 20.0.0.2
  5. In R2, modify the route map aa.

    Type the following:

    iS5comm# configure terminal
    iS5comm(config)# route-map aa permit 1
    iS5comm(config-rmap-aa)# no match destination ip 91.0.0.0 255.0.0.0
    iS5comm(config-rmap-aa)# match destination ip 92.0.0.0 255.0.0.0
    iS5comm(config-rmap-aa)# exit
  6. In R3, verify 91.0.0.0/8 is removed from the general routing table and 92.0.0.0/8 is present in the general routing table.

    Type the following:

    iS5comm# show ip route
    Vrf Name:          default
    C 11.0.0.0/8  is directly connected, vlan130
    C 12.0.0.0/8  is directly connected, vlan1 
    C 20.0.0.0/8  is directly connected, vlan23
    O 92.0.0.0/8  [10] via 20.0.0.2
  7. In R2, add/remove static routes.

    Type the following:

    iS5comm# configure terminal
    iS5comm(config)# ip route 93.0.0.0 255.0.0.0 vlan 24
    iS5comm(config)# no ip route 92.0.0.0 255.0.0.0 vlan 24
    iS5comm(config)# end
  8. In R3, verify 92.0.0.0/8 is removed from the general routing table and 92.0.0.0/8 is present in the general routing table.

    Type the following:

    iS5comm# show ip route
    Vrf Name:          default
    C 11.0.0.0/8  is directly connected, vlan130
    C 12.0.0.0/8  is directly connected, vlan1 
    C 20.0.0.0/8  is directly connected, vlan23
    O 93.0.0.0/8  [10] via 20.0.0.2
  9. Delete the route map aa.

    Type the following:

    iS5comm# configure terminal
    iS5comm(config)# no route-map aa 1
    iS5comm(config)# no route-map aa 2
    iS5comm(config)# exit
  10. In R3, verify 91.0.0.0/8 is removed from the general routing table and 92.0.0.0/8 is present in the general routing table.

    Type the following:

    iS5comm# show ip route
    Vrf Name:          default
    C 11.0.0.0/8  is directly connected, vlan130
    C 12.0.0.0/8  is directly connected, vlan1 
    C 20.0.0.0/8  is directly connected, vlan23
    O 93.0.0.0/8 [10] via 20.0.0.2

OSPF Inbound Filtering with Route Map

This section provides the sample configuration for testing OSPF inbound filtering with route map.

Figure 3. Distribute-list In Topology Configuration


Interface Configuration

Table 4. IPv4 / IPv6 Addresses of Interfaces in the Routers – OSPF Inbound Filtering
Router Interface Ports IPv4 Address / Mask IPv6 Address/ Prefix Length
R1 Vlan 12 Tagged ports E1 10.0.0.1/8 1111::1/64
Vlan 100 Tagged ports E3 20.0.0.1/8 2222::1/64
Vlan 110 Tagged ports E2 130.0.0.1/8 1234::1/64
R2 Vlan 12 Tagged ports E1 10.0.0.2/8 1111::2/64
Vlan 23 Tagged ports E2 30.0.0.2/8 3333::2/64
Vlan 120 Tagged ports E3 100.0.0.2/8 3214::2/64
R3 Vlan 23 Tagged ports E1 30.0.0.3/8 3333::3/64
Vlan 130 Tagged ports E2 120.0.0.3/8 4444::3/64
  Vlan 140 Tagged ports E2 150.0.0.3/8 5555::3/64

Protocol Configuration

Table 5. Protocol Configuration
Router Interface
R1

Configure this as ASBR router.

Interface Vlan 12

Enable OSPFv2/OSPFv3 with Area 0.0.0.0.

Interface Vlan 100

Enable OSPFv2/OSPFv3 with Area 1.1.1.1.

Interface Vlan 110

Enable OSPFv2/OSPFv3 with Area 0.0.0.0.

R2

Interface Vlan 12

Enable OSPFv2/OSPFv3 with Area 0.0.0.0.

Interface Vlan 23

Enable OSPFv2/OSPFv3 with Area 0.0.0.0.

Interface Vlan 120

Enable OSPFv2/OSPFv3 with Area 0.0.0.0

R3

Configure this as ASBR router.

Interface Vlan 23

Enable OSPFv2/OSPFv3 with Area 0.0.0.0.

Interface Vlan 130

Enable OSPFv2/OSPFv3 with Area 0.0.0.0.

Interface Vlan 140

Enable OSPFv2/OSPFv3 with Area 0.0.0.0

  1. Perform the following configurations in R1, R2 and R3:

    Type the following:

    • Configuration at R1
    • Configure R1 as ASBR Router.
    iS5comm# configure terminal 
    iS5comm(config)# router ospf
    iS5comm(config-router)# router-id 0.0.0.1
    iS5comm(config-router)# network 10.0.0.1 area 0.0.0.0
    iS5comm(config-router)# network 130.0.0.1 area 0.0.0.0
    iS5comm(config-router)# network 20.0.0.1 area 1.1.1.1
    iS5comm(config)# router rip
    iS5comm(config-router)#end
    • Configuration at R2
    iS5comm# configure terminal
    iS5comm(config)# router ospf
    iS5comm(config-router)# router-id 0.0.0.2
    iS5comm(config-router)# network 10.0.0.2 area 0.0.0.0
    iS5comm(config-router)# network 30.0.0.2 area 0.0.0.0
    iS5comm(config-router)# network 100.0.0.2 area 0.0.0.0
    iS5comm(config-router)#end
    • Configuration at R3
    iS5comm# configure terminal
    iS5comm(config)# router ospf
    iS5comm(config-router)# router-id 0.0.0.3
    iS5comm(config-router)# network 30.0.0.3 area 0.0.0.0
    iS5comm(config-router)# network 120.0.0.3 area 0.0.0.0
    S5comm(config-router)# network 150.0.0.3 area 1.1.1.1
    iS5comm(config-router)# exit
  2. In R3, create static routes and enable redistribution of static routes.

    Type the following:

    iS5comm# configure terminal 
    iS5comm(config)# ip route 91.0.0.0 255.0.0.0 40.0.24.4
    iS5comm(config)# router ospf
    iS5comm(config-router)# redistribute static
    iS5comm(config-router)#  end
  3. In R2, shutdown interfaces Vlan12 and Vlan23

    Type the following:

    iS5comm# configure terminal
    iS5comm(config)# interface vlan 12
    iS5comm(config-if)# shutdown
    iS5comm(config-if)# end
    iS5comm# configure terminal
    iS5comm(config)# interface vlan 23
    iS5comm(config-if)# shutdown
    iS5comm(config-if)#
  4. In R2, create route map aa and enable incoming filtering of routes in OSPFv2 with route map aa.

    Type the following:

    iS5comm# configure terminal
    iS5comm(config)# route-map aa permit 10
    iS5comm(config-rmap-aa)# exit
    iS5comm(config)# route-map aa deny 1
    iS5comm(config-rmap-aa)# match destination ip 150.0.0.0 255.0.0.0
    iS5comm(config-rmap-aa)# match destination ip 91.0.0.0 255.0.0.0
    iS5comm(config-rmap-aa)# end
    iS5comm(config)# router ospf
    iS5comm(config-router)# distribute-list route-map aa in
  5. In R2, shutdown interfaces Vlan12 and Vlan23

    Type the following:

    iS5comm# configure terminal
    iS5comm(config)# interface vlan 12
    iS5comm(config-if)# no shutdown
    iS5comm(config-if)# end
    iS5comm# configure terminal
    iS5comm(config)# interface vlan 23
    iS5comm(config-if)# no shutdown
    iS5comm(config-if)#end
  6. Wait for one minute for all route updates, and verify the routes in R2.

    Type the following:

    iS5comm# show ip route
    Vrf Name:          default
    C 10.0.0.0/8  is directly connected, vlan12
    C 12.0.0.0/8  is directly connected, vlan1
    O 20.0.0.0/8  [2] via 10.0.0.1
    C 30.0.0.0/8  is directly connected, vlan23
    C 100.0.0.0/8  is directly connected, vlan120
    O 120.0.0.0/8  [2] via 30.0.0.3
    O 130.0.0.0/8  [2] via 10.0.0.1
  7. In R2, shutdown interfaces: Vlan12 and Vlan23

    Type the following:

    iS5comm# configure terminal
    iS5comm(config)# interface vlan 12
    iS5comm(config-if)# shutdown
    iS5comm(config-if)# exit
    iS5comm(config)# interface vlan 23
    iS5comm(config-if)# shutdown
  8. In R2, modify the route map aa.

    Type the following:

    iS5comm# configure terminal
    iS5comm(config)# route-map aa permit 1
    iS5comm(config-rmap-aa)# no match destination ip 91.0.0.0 255.0.0.0
    iS5comm(config-rmap-aa)# match destination ip 92.0.0.0 255.0.0.0
    iS5comm(config-rmap-aa)# exit
  9. Start interfaces Vlan12 and Vlan23.

    Type the following:

    iS5comm# configure terminal
    iS5comm(config)# interface vlan 12
    iS5comm(config-if)# no shutdown
    iS5comm(config-if)# exit
    iS5comm(config)# interface vlan 23
    iS5comm(config-if)# no shutdown
    iS5comm(config-if)# end
  10. Wait for one minute for all route updates and verify the routes in R2.

    Type the following:

    iS5comm# show ip route
    Vrf Name:          default
    C 10.0.0.0/8  is directly connected, vlan12
    C 12.0.0.0/8  is directly connected, vlan1
    O 20.0.0.0/8  [2] via 10.0.0.1
    C 30.0.0.0/8  is directly connected, vlan23
    C 100.0.0.0/8  is directly connected, vlan120
    O 120.0.0.0/8  [2] via 30.0.0.3
    O 150.0.0.0/8  [2] via 30.0.0.3
  11. In R2, shutdown interfaces Vlan12 and Vlan23.

    Type the following:

    iS5comm# configure terminal
    iS5comm(config)# interface vlan 12
    iS5comm(config-if)# shutdown
    iS5comm(config-if)# exit
    iS5comm(config)# interface vlan 23
    iS5comm(config-if)# shutdown
  12. Delete the route map aa.

    Type the following:

    iS5comm# configure terminal
    iS5comm(config)# no route-map aa 1
    iS5comm(config)# exit
  13. Start interfaces Vlan12 and Vlan23.

    Type the following:

    iS5comm# configure terminal
    iS5comm(config)# interface vlan 12
    iS5comm(config-if)# no shutdown
    iS5comm(config-if)# exitiS5comm(config)# interface vlan 23iS5comm(config-if)# no shutdowniS5comm(config-if)#end
    iS5comm(config)# exit
  14. Wait for one minute for all route updates, and verify the routes in R2.

    Type the following:

    iS5comm# show ip route
    Vrf Name:          default
    C 10.0.0.0/8  is directly connected, 
    vlan12C 12.0.0.0/8  is directly connected, 
    vlan1O 20.0.0.0/8  [2] via 10.0.0.1
    C 30.0.0.0/8  is directly connected, vlan23
    O 91.0.0.0/8  [10] via 30.0.0.2
    C 100.0.0.0/8  is directly connected, vlan120
    O 120.0.0.0/8  [2] via 30.0.0.3
    O 130.0.0.0/8  [2] via 10.0.0.1
    O 150.0.0.0/8  [2] via 30.0.0.3